Forums - libSNPE 1.54.2.2899 require GLIBC_2.29 version

2 posts / 0 new
Last post
libSNPE 1.54.2.2899 require GLIBC_2.29 version
luan1412167
Join Date: 23 Dec 21
Posts: 1
Posted: Tue, 2022-01-11 20:31

Hi everyone,

I'm using snpe 1.54.2.2899 on Ubuntu 18.04 based on RB5 board.

I'm facing the following problem

ImportError: /lib/aarch64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by ./snpe/libs/aarch64-oe-linux-gcc9.3/libSNPE.so)

How can I try to solve it? I need to downgrade snpe version or reinstall GLIBC?

How can I do? I wonder that RB5 only support Ubuntu 18.04 image as of now, right?

Really need your support soon. Thank you in advance

  • Up0
  • Down0
weihuan
Join Date: 12 Apr 20
Posts: 40
Posted: Sun, 2022-01-16 17:38

Dear customer,

We have no any idea if you run SNPE on X86 since this engine is devleoped for our Qualcomm devices instead of X86. The X86 is supported for model conversion, quantization and accuracy checking.

Please move to devices and verify your task again.

BR.

Wei

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.