Forums - Firmware Issue- Unable to boot SA6155P

2 posts / 0 new
Last post
Firmware Issue- Unable to boot SA6155P
kumar.anshuman
Join Date: 26 Mar 20
Posts: 1
Posted: Mon, 2021-07-19 03:15
Hi,

We are having SA6155P ADP Air board, we had the Snapdragon_Auto_Gen3.LV.0.1
version 6.1 flashed.

While we were testing CAN, we got the message to update the latest can
firmware.
SO we tried to update the firmware files for CAN

  adb root && adb shell mount -o remount,rw /
    adb push mpc5746c_firmware_A.bin /etc/firmware/
    adb push mpc5746c_firmware_B.bin /etc/firmware/
    adb shell
    canflasher -c can0


After canflasher command ran successfully, we tried to reboot the board. 

But the board is not booting up. We are not getting any log message either in
minicom or through adb shell.

We are unable to reflash using QFIL tool as well, since the PORT is not getting
detected.

Please help urgently.
  • Up0
  • Down0
gmcgrath
Join Date: 21 Aug 13
Posts: 58
Posted: Mon, 2021-07-26 12:39

This is clearly not an ADAS SDK issue.

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.