Forums - RB5 PWM output problem

2 posts / 0 new
Last post
RB5 PWM output problem
867757636
Join Date: 22 Jul 21
Posts: 1
Posted: Thu, 2021-07-22 02:41

To whom it may concern:

I have downloaded sample projects code from the website https://github.com/quic/sample-apps-for-Qualcomm-Robotics-RB5-platform. In GPIO-samples, when I run 5. Simple PWM output code, I don't know in which GPIO port can I get the PWM signal, so that no PWM signal can be detected when the PWM parameter is changed. Can anyone tell me which is the default output GPIO port of PWM?

In addition, when I set the second parameter of PWM to 1 (namely,/qrb5165_platform -pwm 1 1000 500), there will be a parameter error. When the second parameter of PWM is set to 0 (namely, /qrb5165_platform -pwm 0 1000 500), the code can be run.

Why would this be?

Any advice would be really appreciated. Thanks.

  • Up0
  • Down0
mitarath
Join Date: 21 Jun 21
Posts: 8
Posted: Fri, 2021-07-23 10:32

Hello customer

Regarding GPIO port for PWM is Pin 12 and Pin 14 on LS2.
regarding setting PWM parameter , we are checking and will update soon

Thanks,
Mita

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.