Forums - QCLI Demo - Mesh

2 posts / 0 new
Last post
QCLI Demo - Mesh
jalamani
Join Date: 21 Oct 21
Posts: 5
Posted: Thu, 2021-12-16 14:38

I am trying to add an application key in the QMesh Config Model  submenu following 80-Y9381-4 using the ConfigAddAppKey command

15 0 33 0 0 1234567890ABCDEF1234567890ABCDEF

but the console returns res=4 which in the QAPI is an invalid network key index.

Is the first argument not supposed to refer to the network index used in the QMesh submenu using the AddNetwork command?

 

  • Up0
  • Down0
raja_pedada
Profile picture
Join Date: 18 Jun 18
Location: San Jose
Posts: 315
Posted: Fri, 2022-05-13 15:20

ConfigAddAppKey and ConfigBindAppKey have to be run from the provisioner targeted to the node.
Example:
QMesh InitializeMesh
QMesh CreateDeviceInstance 0 0 0
QMesh AddNetwork 0 0 88d7364cd842ad18c17c2b820c848899
QMesh AddApplicationKey 0 0 0 5516D1509884B533248541792B888F9a
QMesh AddApplicationKey 0 0 1 6688D1509884B533248541792B877F88
QMesh UpdateModelAppBindList 0 0x465 0 0x1001 0 1
QMesh UpdateModelAppBindList 0 0x465 1 0x1309 0 1

 

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.