Forums - Problems connecting to devices running BT 5.1 and BT5.2

2 posts / 0 new
Last post
Problems connecting to devices running BT 5.1 and BT5.2
andreas
Join Date: 21 Oct 19
Posts: 31
Posted: Fri, 2021-08-06 06:38

Hi,

we are using the BLE functionality of the QCA4020 which works very well with devices that run BT5.0 or lower. Now we encountered that if we try to connect with devices that run BT V5.1 or V5.2 it does not work anymore. These devices are smartphones (Android 11) which implement these mentioned BT versions. The problem seems to appear during the pairing/bonding phase of the connection. We are running on QCA SDK3.3.
We do not do fancy stuff with BLE and are following the example code in QCLI demo.

Are there any known incompatibilities of the BT versions? Does someone have a hint if a different BLE configuration on our side can help solving the issue?

Any help is much appreachiated

thanks and regards,

Andreas

  • Up0
  • Down0
raja_pedada
Profile picture
Join Date: 18 Jun 18
Location: San Jose
Posts: 315
Posted: Tue, 2022-05-10 15:33

The fix for compatibility issue with certain smartphones using BT V5.1 and V5.2 is resolved in upcoming post CS3.5 release

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.