Forums - Adreno Profiler with Galaxy S4

13 posts / 0 new
Last post
Adreno Profiler with Galaxy S4
eric.charpenay
Join Date: 22 May 13
Posts: 1
Posted: Tue, 2013-05-28 08:12

Hello,

I am trying to use the Adreno Profiler (v3.3) with a Samsung Galaxy S4. I have installed the following USB drivers : http://developer.samsung.com/android/tools-sdks/Samsung-Andorid-USB-Driver-for-Windows

But when my device is in USB debugging mode, the USB driver fails to recognize my device. Is there something I have missed ? Has anyone succeed using the Adreno Profiler with a Galaxy S4 ?

Thanks

  • Up0
  • Down0
h_karthik
Join Date: 25 Jun 13
Posts: 4
Posted: Tue, 2013-07-02 07:28

Hi Eric,

  Have you succeeded using the profiler with Galaxy S4?

Cheers

Karthik

 

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Wed, 2013-07-03 03:43

Same problem here. I'm trying to use Adreno Profiler 3.4.4918.22992 with stock Samsung Galaxy S4 I9505.

Profiler detects the adb but doesn't find any apps to be profiled.

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Wed, 2013-07-03 06:21

This is high priority for my company, because we try to investigate why our game freezes inside glSwapBuffers() on Adreno 320. The game works fine on other devices such as those based on Adreno 2xx, Tegra 2/3 and SGX 5xx. We are hoping the Profiler will give us some clues what happens and possible workaround.

 

 

  • Up0
  • Down0
Dave Astle
Profile picture
Join Date: 19 Oct 12
Location: San Diego, CA
Posts: 101
Posted: Wed, 2013-07-03 07:07

Unfortunately, after investigation on our part, it looks like the SGS4 shipped with a build on which Adreno Profiler is broken. We've since provided a fix to Samsung, so it'll eventually make it out in an OTA update, but I don't know when that will be (and it probably depends on your carrier).

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Wed, 2013-07-03 07:17

Thanks for the information!

What other Adreno 320 based devices are known to work with the Adreno Profiler 3.4?

Sony Experia Z? HTC One?

 

 

  • Up0
  • Down0
Dave Astle
Profile picture
Join Date: 19 Oct 12
Location: San Diego, CA
Posts: 101
Posted: Wed, 2013-07-03 09:21

The Nexus 4 definitely works (although you may have to push updated driver binaries from our downloads page), and I've personally used it with an LG Optimus G. I'll see if I can get my hands on the phones you mentioned and verify personally, but I've not heard of any issues with them.

  • Up0
  • Down0
Dave Astle
Profile picture
Join Date: 19 Oct 12
Location: San Diego, CA
Posts: 101
Posted: Wed, 2013-07-03 13:44

I tested with the HTC One, and Profiler works with it without issues.

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Wed, 2013-07-03 14:17

Thanks!

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Tue, 2013-07-09 07:03

I've got some more information. Here's a log from Galaxy S4 (Adreno 320, Android 4.2.2)

 

07-09 15:47:39.791: I/Adreno200-EGL(5130): <qeglDrvAPI_eglInitialize:265>: EGL 1.4 QUALCOMM build:  (CL3544079)
07-09 15:47:39.791: I/Adreno200-EGL(5130): Build Date: 03/28/13 Thu
07-09 15:47:39.791: I/Adreno200-EGL(5130): Local Branch: adreno_20130328
07-09 15:47:39.791: I/Adreno200-EGL(5130): Remote Branch:
07-09 15:47:39.791: I/Adreno200-EGL(5130): Local Patches:
07-09 15:47:39.791: I/Adreno200-EGL(5130): Reconstruct Branch:
*** Here is where our game runs fine for about 100 frames. ***
07-09 15:48:01.973: W/Adreno200-GSL(5130): <gsl_ldd_control:357>: ioctl fd 58 code 0x400c0907 (IOCTL_KGSL_DEVICE_WAITTIMESTAMP_CTXTID) failed: errno 4 Interrupted system call
07-09 15:48:01.973: W/Adreno200-EGLSUB(5130): <updater_thread:444>: waitFunc failed
07-09 15:48:11.272: W/Adreno200-EGLSUB(5130): <updater_thread:449>: native buffer is NULL
07-09 15:48:38.278: W/Adreno200-EGLSUB(5130): <updater_thread:449>: native buffer is NULL

 

Let me say that our game runs fine on:

- iOS devices

- Android tablets based on Tegra 2&3

- Android devices based on PowerVR

 

gl functions don't return any errors. The game will freeze inside glSwapBuffers(). By this point I have been systematically removing parts of code but nothing helps. It always hangs inside glSwapBuffers().

I could provide APK if you guys could take a look?

 

 

  • Up0
  • Down0
damjan12
Join Date: 3 Jul 13
Posts: 6
Posted: Tue, 2013-07-09 10:21

APK: http://www.kulfun.com/cve.apk

 

When you start the game, it should show a welcome splash screen and a loading bar. It takes about 10 seconds to load. Once loading bar reaches the end, it should switch to a bunch of clouds starting to clear. At this point it usually freezes or terminates the app.

 

The errors from Adreno driver actually happen some time before the actual freeze/termination. So they might give a clue to what is happening. Sometime there is no error at all, but the game still freezes or terminates.

 

Here are some more errors:

07-09 18:48:35.106: W/Adreno200-GSL(5435): <gsl_ldd_control:357>: ioctl fd 54 code 0x400c0907 (IOCTL_KGSL_DEVICE_WAITTIMESTAMP_CTXTID) failed: errno 4 Interrupted system call
07-09 18:48:35.106: W/Adreno200-EGLSUB(5435): <updater_thread:444>: waitFunc failed
07-09 18:48:37.358: W/Adreno200-GSL(5435): <gsl_ldd_control:357>: ioctl fd 54 code 0x400c0907 (IOCTL_KGSL_DEVICE_WAITTIMESTAMP_CTXTID) failed: errno 4 Interrupted system call
07-09 18:48:37.358: W/Adreno200-EGLSUB(5435): <updater_thread:444>: waitFunc failed
07-09 18:48:48.719: W/Adreno200-EGLSUB(5435): <DequeueBuffer:473>: dequeue native buffer fail: Interrupted system call
07-09 18:48:48.719: W/Adreno200-ES20(5435): <gl2_surface_swap:43>: GL_OUT_OF_MEMORY
07-09 18:48:48.719: W/Adreno200-EGL(5435): <qeglDrvAPI_eglSwapBuffers:3514>: EGL_BAD_ALLOC
07-09 18:48:52.833: W/Adreno200-GSL(5435): <gsl_ldd_control:357>: ioctl fd 54 code 0x400c0907 (IOCTL_KGSL_DEVICE_WAITTIMESTAMP_CTXTID) failed: errno 4 Interrupted system call
07-09 18:48:52.833: W/Adreno200-EGLSUB(5435): <updater_thread:444>: waitFunc failed
07-09 18:48:53.124: W/Adreno200-GSL(5435): <gsl_ldd_control:357>: ioctl fd 54 code 0x400c0907 (IOCTL_KGSL_DEVICE_WAITTIMESTAMP_CTXTID) failed: errno 4 Interrupted system call
07-09 18:48:53.124: W/Adreno200-EGLSUB(5435): <updater_thread:444>: waitFunc failed
 

  • Up0
  • Down0
kakrala.amit
Join Date: 24 Mar 14
Posts: 2
Posted: Wed, 2014-04-09 06:04

Hi ,

I was trying to profile simple openCL application with Adreno Profiler on samsung phone, namely S5.

Following requirements were met:

1) APK manifest was modified for permission.

2) PATH variable modified accordingly.

3) Device connected to profiler -Success.

4) Insatnce of ScrubberCL launched.

Problem : CApture button for starting the process is inactive, can't be turned on.

Tried with both one-shot applications and Periodic Applications, but still capture button is inactive.

Has anyone faced the same problem, or know the solution?

Thanks

  • Up0
  • Down0
khawkins Moderator
Join Date: 29 Nov 12
Location: San Diego, CA
Posts: 62
Posted: Fri, 2014-04-11 13:26

We haven't been able to duplicate your problem with the S5. What build is on your S5 device? 

  • Up0
  • Down0
or Register

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.