Forums - ROS camera streaming example not working

1 post / 0 new
ROS camera streaming example not working
suhassajjan3
Join Date: 29 Jul 19
Posts: 1
Posted: Wed, 2019-08-07 23:36

Hi,

 
 I am encountering some issue when trying  to run ROS camera streaming example. I am able to build and run successfully below both the application on Docker Container, but when i am trying to run the same application on Flight Pro hardware i am getting continuously.
 
/bin/sh: /tmp/setup.sh.XXXXX:line 1:#: not found. 
 
i have tried almost more than 1.5 hours but nothing worked. Please let me know if any thoughts of yours
 
Below is the log for the roslaunch snap_cam_ros hires.launch on Docker container, is running fine.
==================================================
~/ros/src/snap_cam_ros # roslaunch snap_cam_ros hires.launch
... logging to /home/root/.ros/log/f67c44f8-b923-11e9-91d8-0022fb899506/roslaunch-qual5-Latitude-E6400-2847.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://qual5-Latitude-E6400:37160/

SUMMARY
========

PARAMETERS
 * /hires/snap_cam_nodelet/camera_name: hires
 * /hires/snap_cam_nodelet/camera_number: 0
 * /hires/snap_cam_nodelet/format: 1
 * /hires/snap_cam_nodelet/frame_id: hires
 * /hires/snap_cam_nodelet/height: 480
 * /hires/snap_cam_nodelet/skip_n_frames: 0
 * /hires/snap_cam_nodelet/width: 640
 * /hires/snap_cam_nodelet/yuv_remap: mono
 * /rosdistro: indigo
 * /rosversion: 1.11.21

NODES
  /hires/
    hires_nodelet_manager (nodelet/nodelet)
    snap_cam_nodelet (nodelet/nodelet)

auto-starting new master
process[master]: started with pid [2900]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to f67c44f8-b923-11e9-91d8-0022fb899506
process[rosout-1]: started with pid [2920]
started core service [/rosout]
process[hires/hires_nodelet_manager-2]: started with pid [2925]
[ INFO] [1565189979.421412253]: Initializing nodelet with 2 worker threads.
process[hires/snap_cam_nodelet-3]: started with pid [2942]
[ INFO] [1565189981.025534133]: SnapCamDriver Starting
[ INFO] [1565189981.028526744]: Monotonic offset: 1565179917.562046777
/home/root/ros/src/snap_cam_ros/snap_cam_manager/src/SnapdragonCameraManager.cpp 91
 
I look forward for your inputs
 
Best Regards,
Suhas Sajjan
  • Up0
  • Down0

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.