Forums - Documents

1 post / 0 new
Documents
yehon2
Join Date: 2 Feb 19
Posts: 1
Posted: Mon, 2019-04-01 13:30
Dear Madam/Sir
 
I need help to create and compile a simple ros package.
 
The official documentation on GitHub (https://github.com/ATLFlight/QFlightProDocs) refers me to building on a docker container, however it states that the docker has not yet made available. I also can't find a docker container available for download.
 
Furthermore, The tab in the official documentation titled as "Working With ROS" is also unavailable (broken link - page not found).
 
I also tried to build a workspace and compile on the device. when I run catkin_create_pkg, I get the following error message implying that the installation of the catkin package is broken:
 
"
bash-4.3# catkin_create_pkg test
Traceback (most recent call last):
  File "/usr/bin/catkin_create_pkg", line 10, in <module>
    from catkin_pkg.package_templates import create_package_files, PackageTemplate
  File "/usr/lib/python2.7/site-packages/catkin_pkg/package_templates.py", line 35, in <module>
    import getpass
ImportError: No module named getpass
"
 
How do I compile and build a simple ROS program? 
  • Up0
  • Down0

Opinions expressed in the content posted here are the personal opinions of the original authors, and do not necessarily reflect those of Qualcomm Incorporated or its subsidiaries (“Qualcomm”). The content is provided for informational purposes only and is not meant to be an endorsement or representation by Qualcomm or any other party. This site may also provide links or references to non-Qualcomm sites and resources. Qualcomm makes no representations, warranties, or other commitments whatsoever about any non-Qualcomm sites or third-party resources that may be referenced, accessible from, or linked to this site.