Snapdragon Neural Processing Engine SDK
Reference Guide
ONNX setup

In order for the SNPE SDK to be used with ONNX, an ONNX installation must be present on the system.

Follow the instructions at https://github.com/onnx/onnx#installation to install ONNX on Ubuntu Linux, then continue with the rest of the SNPE Setup.

Note that ONNX requires protobuf 2.6.0 or greater and numpy 1.9.0 or greater. Both of these are later versions than those used by SNPE. Users operating on a base 14.04 image will need to upgrade these manually before installing ONNX.